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NetworkAdminKB.com > Knowledge Base > Knowledge Base > Windows2003 > How to troubleshoot Event IDs 2508 and 7023  

How to troubleshoot Event IDs 2508 and 7023

Author Details
Author: NetworkAdminKB.com
Created: 2006-05-24
Modified: 2008-11-19
Article Content

Issue:

The Server service will not start manually or with a reboot.

 

The following system events appear in the Event Viewer:

Event ID: 2508

Source: Server

Type: Error

Description: The server service was unable to load the server driver.

 

Event ID: 7023

Source: Service Control Manager

Type: Error

Description: The Server service terminated with the following error:

The specified driver is invalid.


When you attempt to manually start the Server service you get a dialog box:

Could not start the Server service on local Computer.

 

Cause:

Srv.sys is the Server service driver file.  Depending on the error message this file may be either corrupt, missing, or the wrong version, etc.  In this case the %systemroot%\system32\drivers\srv.sys file is corrupt and needs to be replaced. 

 

The indicator of the corrupt drive is the 7023 event id and the specific error message

“The specified driver is invalid”

 

Solutions:

To replace a corrupt / invalid srv.sys file.

 

All operating systems:

1)      Run Chkdsk %systemdrive% /F

a.       This will fix any corrupt sectors on the drive

b.      Reboot if needed to make sure this runs.

 

Windows 2000 and 2003

1)      Copy %systemroot%\system32\drivers\srv.sys to a temporary location as a backup.

2)      Delete the %systemroot%\system32\drivers\srv.sys file.  The file protection service will automatically replace the file with one from the   %systemroot%\system32\dllcache folder.

3)      Start the Server Service

 

Windows NT 4 and below

1)      Copy %systemroot%\system32\drivers\srv.sys to a temporary location as a backup.

2)      Right click the srv.sys file and find the file version and file size information.

3)      Search Microsoft (or google) the filename and file version to determine what service pack or security patch was applied.

4)      Delete the %systemroot%\system32\drivers\srv.sys file.

5)      Replace the file using one of these methods

a.       Download service pack / security patch and extract the srv.sys file

                                                               i.      Copy the file to %systemroot%\system32\drivers\

b.      Reinstall the service pack / security patch.

                                                               i.      You may need to un-install the security patch if it is listed as already installed.

c.       Find the same version of the srv.sys on another computer and copy it to the local computer.

d.      Restore the file from a recent backup.

6)      Start the Server Service

 

To replace a missing srv.sys file re-run the last service pack / security patch or restore it from a backup.

 

To correct a file version problem delete the srv.sys file and re-run the last service pack / security patch or restore it from a backup.

 

A final solution would be to do an in-place upgrade to a newer operating system.  For example upgrade NT4 to Windows 2000, or Windows 2000 to Windows 2003, etc.  This will fix the problem by simply replacing all the current files (regardless of version or corruption) with files from the new operating system. 

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Last modified at 11/19/2008 10:01 AM  by TEMPLATE\kbadmin 
 
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