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NetworkAdminKB.com > Knowledge Base > Knowledge Base > Windows2003 > How to Performance Tune for PST file performance and access issues  

How to Performance Tune for PST file performance and access issues

Author Details
Author: NetowrkAdminKB.com
Created: 2006-05-25
Modified: 2008-12-03
Article Content

Issue:

When users access PST files from a Windows 2003 file server they may experience performance issues, or the PST file may not function properly.  After a few minutes the issue may go away and the PST file may perform well without issue.  The problem may present itself sporadically or only during specific times of the day (like in the morning, or after lunch).

 

Examples of Common Error Messages associated with PST file issues.

Microsoft Outlook 2002, you may receive the following error message:

Unable to expand the folder. The set of folders could not be opened.

 

In Microsoft Office Outlook 2003, you may receive the following error message:

Unable to expand the folder. Microsoft Office Outlook could not access the specified folder location.

 

Other General Errors Outlook Clients may receive

            The handle is invalid.

 

Cause:

The most likely cause of the PST file issue is pagedpool memory depletion, but can be caused by other things.  By default Windows 2003 file servers with 4GB of RAM display slowness or other issues when the pagedpool memory reaches about 160MB (163,840KB) of utilization.  When pagedpool memory reaches this level of utilization various programs may have intermittent and unexplained issues, slowness, etc.  PST files happen to be greatly affected by this issue.

 

Below is an example of a file server with 4GB of RAM and very high pagedpool memory utilization (152,320KB = 148.75GB)

 

As the pagedpool fills up the system will attempt to trim the amount of pagedpool usage back so new requests can be handled.   However, if the new requests come in before the system has made room in the pagedpool memory, intermittent errors and performance issues may occur.

 

Solution:

The issues regarding the PST file performance and other access related issues center around being able to diagnose and tune a file server for the workload that it is being asked to perform.  PST files present a unique challenge because of their large use of pagedpool memory.  The general solution to correct this issue is to increase the amount of pagedpool memory and start trimming the pagedpool memory back sooner.  This will allow all new requests to always be handled without risk of filling up pagedpool memory.

 

 

The following are Best Practices for configuring a Windows 2003 Server to host large numbers of PST files.  These Best Practices are only recommended on file servers that have 4GB or more of RAM.  If you do not have that much RAM in your file server you should add memory before attempting these changes.

 

1)      Use multiple 15K drives in a RAID 5 or RAID 6 (dual parity) configuration.

a.       Many smaller drivers are better than a few larger drives.

2)      Limit your total disk space to 2TB per server.

a.       2TB per server is a good rule of thumb for how much data a single file server can support and still perform well under load.

3)      Purchase as much Cache on the RAID controller as you can, or use a Fiber Channel SAN.

4)      Configure File and Printer Sharing for Microsoft Networks

a.       Maximize data throughput for file sharing

5)      Configure Advance Computer Performance Settings

a.       Select Background services

b.      Select System cache

6)      DO NOT use the /3GB switch in the boot.ini on any file server

a.       This setting significantly reduces pagedpool memory and is only for use on application servers.

7)      DO NOT install any additional applications or services on a file server.

a.       Examples of applications and services NOT to install (i.e. Remove them if installed).

b.      Domain Controller

c.       DHCP, DNS or WINS Services

d.      Internet Authentication Service (IAS)

e.       Routing and Remote Access Service

f.        Exchange Server

g.       SQL Server

h.       IIS Server or Windows Sharepoint Services

i.         Terminal Server for Applications

8)      DO NOT configure the file server as a Print Server

a.       Instead use a different server as the Print Server

9)      On the file server, disable realtime scanning of PST files by Virus Scanning software.

a.       Unless your virus scanning software can open and read the contents of the PST file, scanning a PST for viruses is not beneficial.

b.      If your Virus Scanning software does open and scan the contents of PST files, consider disabling realtime scanning of PST files increase performance.  Schedule a scan of PST files after hours.

c.       Virus scanning software makes significant use of the pagedpool memory.

d.      Virus scanning of all email should take place on the Email server not the file server.

10)  Maximize the amount of pagedpool memory available on the file server.

a.       Open Regedit and go to the following key.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

b.      Select: PagedPoolSize

c.       Set value: 0xFFFFFFFF (hexadecimal)

11)  Configure pagedpool memory to start trimming the pagedpool usage at 60 percent full

a.       Open Regedit and go to the following key.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

b.      Select: PoolUsageMaximum

c.       Set value: 0x3c (hexadecimal, or 60 decimal)

12)  Reboot Server

13)  Monitor the server to see if the problem still persists.

14)  If the problem persists continue reducing the value of PoolUsageMaximum by increments of 10 until you reach 30 (i.e. try 50, 40, 30) until the problem no longer exists.

a.       Make sure to Reboot have each change.

b.      If the problem persists with a PoolUsageMaximum setting of 30 then the issue is most likely not pagedpool memory.

 

More Information:

Resolving the pagedpool memory issue on the file server may uncover other performance issues.  However, all these other issues will typically have associated Events in the System or Application Event Log.  You should monitor those logs for any new errors or warning messages, then work to resolve those bottlenecks in your file server as well.

 

For extremely large environments (2000+ users) I would suggest multiple file servers to balance the load of the PST files across.

 

Here is a screen shot showing pagedpool memory usage after these changes.

 

It should also be noted that Microsoft has a KB article and a blog posting about PST files and why they are unsupported on a file server.  While Microsoft makes this claim for various reasons, I believe the technical issues they mention relate to being able to performance tune your file server and are not a technological limitation of the file server.  Therefore with proper planning, testing, and configuration of your file server you should be able to support PST files on any file server or servers as required and provide proper performance to your users.

 

Network Stored PST files ... don't do it!

 

Personal folder files are unsupported over a LAN or over a WAN link

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Last modified at 12/3/2008 6:33 PM  by TEMPLATE\kbadmin 
 
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