Issue:
You receive one or more of the following errors, and the Citrix Independent Management Architecture (IMA) service fails to start.
Event Source: Service Control Manager
Event ID: 7024
Description:
The Citrix Independent Management Architecture service terminated with service-specific error 2147483649 (0×80000001).
Event Source: IMAService
Event ID: 3601
Description:
Failed to load initial plugins with error IMA_RESULT_FAILURE
Event Source: IMAService
Event ID: 3609
Description:
Failed to load plugin C:\Program Files\Citrix\System32\Citrix\IMA\SubSystems\ImaRuntimeSS.dll with error IMA_RESULT_FAILURE
Event Source: IMAService
Event ID: 3609
Description:
Failed to load plugin C:\Program Files\Citrix\System32\Citrix\IMA\SubSystems\ImaPsSs.dll with error IMA_RESULT_FAILURE
Event Source: IMAService
Event ID: 3989
Description:
The Citrix Presentation Server failed to connect to the Data Store. ODBC error while connecting to the database: S1000 -> [Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key ‘Temporary (volatile) Jet DSN for process 0×1ac Thread 0×730 DBC 0×669c1c Jet’.
Cause:
The Local Host Cache (LHC) of the Citrix Database may have been corrupted, or may have incorrect information in to from recent changes made to the Citrix servers (like name, ip address, etc.). This may also occur if you have made other changes to the farm data store, such as publishing various applications, adding or removing servers from the farm, or creating new policies.
Solution:
Run the following command to delete and recreate the LHC.
dsmaint recreatelhc
Start the Citrix IMA Service
Note: The Citrix IMA Service should always be stopped when running this command.
More Information:
Function of the Local Host Cache