How to Repair the VMware Update Manager Database or Installation files

Author: NetworkAdminKB.com
Created: 2009-07-03
Modified: 2009-10-31

Issue:

The Update Manager Database Service will not start.

 

Cause:

You have made configuration changes to the Update Manager installation.

Examples:

  • Change the VirtualCenter logon user id or password
  • Moved the Update Manager Database to a new server.
  • Move the VirtualCenter server to a new server.
  • Changed the User ID or password for the DSN to connect to the Update Manager Database

 

Solution:

Use Add/Remove Programs to repair the corrupted installation or database, or to update the DSN user information.

 

1)      Click the Change Button on the VMWare Update Manager item in Add/Remove programs

2)      Program Maintenance Screen

a.       Select Repair

3)      VirtualCenter Server Information screen

a.       Click Next

4)      VMWare Update Manager Database screen

a.       Select Use an existing database server

b.      Click Next

5)      Database Information screen

a.       Run ODBC DSN Setup as needed

b.      Enter the appropriate user id and password

c.       Click Next

6)      Existing DB warning

a.       Click NO – if you want to keep the database

b.      Click Yes – if you want to reinitialize the database

7)      Update Manager Port settings

a.       Accept default ports

b.      Enter proxy server information if needed

c.       Click Next

8)      Ready to Repair screen

a.       Click Install

 

More Information:

You can also use this procedure to create a new Update Manager Database on a new or existing server.

Article ID: 196, Created On: 9/17/2011, Modified: 9/17/2011